
Tracking Macromedia Flash (SWF) Movies 

This tracking kit instructs ad developers how to prepare Macromedia Flash (SWF) files so that ad 
serving networks can dynamically assign click codes to Macromedia Flash advertisements. 
Historically, ad developers had to create individual Macromedia Flash advertisements for each 
domain that the banner would be served on. By adhering to this standard ad developers now only 
need to create one Macromedia Flash advertisement for an entire campaign. 

The leading ad serving networks-DoubleClick, Engage, L90, TargetNet, and 24/7Media have 
come together to support this standard for tracking Macromedia Flash movies. 
  
Designer’s Guide how to build Macromedia Flash banners with tracking capabilities 
  
By adopting this standard ad agencies and designers can implement a one time solution for 
tracking their creative units.  Advertisers will have better data to determine the ROI of their 
campaigns.  
 
Ad Serving Network’s Guide to trafficking Macromedia Flash banners 
 
By adopting this standard methodology to implement click tags for Macromedia Flash 
advertisements, ad serving networks will reduce deployment time and engineering costs in 
addition to increasing deployment times for rich media campaigns. 
 
For more tips on how to improve your campaign read Macromedia's rich media 
recommendations.  
 
For source codes and documentation of the examples in this guide, 
download the Rich Media Tracking Kit for PC or Mac. 

Please note: These files must be posted on an http:// web server in order to function correctly. 
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Designer’s Guide how to build Macromedia Flash banners with tracking capabilities 

By adopting this standard ad agencies and designers can implement a one-time solution for 
tracking their creative units and advertisers will have better data to determine the ROI of their 
campaigns.  Prior to starting any campaign we recommend contacting the ad-serving network you 
will be working with to ensure you are using the most current specifications.  
 

 
How to insert click throughs into a Flash Banner ............................................. 3 

To create a new button ............................................................................... 3   
To assign a simple action to a button (Flash 4 or earlier) ........................... 4 
To assign a simple action to a button (Flash 5) .......................................... 5  
 

 
Learn how to assign a clickTAG for your advertisement................................... 6 

Workflow diagram of how a variable is passed from the Macromedia  
Flash ad to the ad serving network ............................................................. 7 
Additional information.................................................................................. 7 

 
 

 

 

   



 3

How to insert click throughs into a Flash Banner 

Click able elements in Flash are most commonly assigned to buttons. Buttons are a special type 
of symbol that contains 4 frames.  Each frame of a button symbol represents a different "state" for 
the button: Up, Over, Down, and Hit. How a button visually behaves when the mouse is rolled 
over it or when the user clicks on the button is determined by these four states. This document 
explains how to create a basic button.  

To create a new button, do the following:  

1. Select Insert > New Symbol, or press Control+F8 (Windows) or Command+F8 (Macintosh). 
 
Note: In Flash 3 and earlier, deselect everything on the stage and choose Insert > Create 
Symbol 
 

2. In the Symbol Properties dialog box, enter a name for the new button symbol and choose 
Button as the Behavior option. Click Ok. 
 
Flash switches to symbol-editing mode. The Timeline header changes to display four 
consecutive frames labeled Up, Over, Down, and Hit. The first frame, Up, is a blank key 
frame. 
 

3. To create the Up state button image, use the drawing tools, import a graphic, or place an 
instance of another symbol on the Stage. You can use either a movie clip or graphic symbol 
in a button, but you cannot use another button in a button. Use movie clip symbols if you 
want to create an animated button. 
 

4. Select the second frame, labeled Over, and choose Insert > Key frame. The button image 
from the first frame appears on the Stage. 
 

5.Change the button image for the Over state; repeat steps 4 and 5 for the Down frame and the 
Hit frame. 
 
Note: The Hit frame is not visible on the Stage on playback, but it defines the area of the 
button that responds when clicked. Make sure that the graphic for the Hit frame is a solid 
area large enough to encompass all the graphic elements of the Up, Down, and Over frames. 
It can also be larger than the visible button. If you do not specify a hit frame, the objects in the 
Up state are used as the hit frame. 
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6. After defining the images of the four button states, choose Edit > Edit Movie to exit 

Symbol Edit mode. 
 

7. Open the Library window by choosing Window > Library. Locate the button in the Library 
window and then drag the button symbol out of the Library onto the Stage. This creates 
an instance of the button in the movie. 

For information on assigning actions to the button instance refer to the documentation that 
applies the version of Flash that you are using. The documentation follows below: 

 
To assign a simple action to a button (Flash 4 and earlier): 
 
1. In Edit Movie mode, select the button instance created in Step 7 above. 

2. Make sure that Enable Buttons from the Control menu is unchecked. 
3. Double-click the button to get the Instance Properties dialog box. 

 
Note: In Flash 2 this was the Link Properties: Button dialog box 
 

4. Assign the action by selecting the Action tab in the Instance Properties dialog box. Then, 
click the plus (+) button and double-click on the appropriate action. 
 
Note: In Flash 2 assign the action using the Action pop-up menu in the Link Properties: 
Button dialog box. Only one action may be assigned to the button. 
 

5. Make sure that Enable Buttons in the Control menu is checked, so that option is toggled 
back on. 

If the selected action has any associated parameters, those parameters will appear in the 
Parameter panel on the right side of the Actions panel. Choose or type the parameters 
appropriate for that action. 
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To assign a simple action to a button (Flash 5): 
 
1. In Edit Movie mode, select the button instance created in Step 7 above. 

2. Choose Window > Actions to open the Actions panel. 
 

3. In the Toolbox list on the left side of the panel, click the Basic Actions category to display 
the basic actions. 
 

4. To assign an action, do one of the following:  
- Double-click an action in the Basics Actions category. 
- Drag an action from the Basic Actions category on the left to the Actions list on the right 
side of the panel. 
- Click the Add (+) button and choose an action from the pop-up menu. 
 

5. If the chosen action has any associated parameters, those parameters will appear in the 
Parameter pane at the bottom of the Actions panel. (If the Parameter pane is not visible 
click the small triangle in the lower right corner of the panel.) Choose or type the 
parameters appropriate for that action. For example, the getURL action shown below 
contains three parameters: URL, Window, Variables and an option for Expression.  
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Learn how to assign a clickTAG for your advertisement 
 
The clickTAG is the tracking code assigned by the ad-serving network to an individual ad.  
The clickTAG allows the network to register where the ad was displayed when it was clicked 
upon. This click through data is reported to the ad-serving servers so advertisers may 
determine the effectiveness of their campaign. 
 
By using the code below, designers will provide ad serving networks the ability to dynamically 
assign a clickTAG to their ad. 
 
In this example a getURL action is being assigned to a button that will navigate the browser 
to ["clickTAG"]. The “getURL(clickTAG)” statement appends the variable data passed in via 
the OBJECT EMBED tag and navigates the browser to that location.  It is the tracking code 
assigned by the ad-serving network, which allows them to register a users click on that 
advertisement. 
 
<EMBED src="ad_banner_example.swf?clickTAG= 
http://adnetwork.com/tracking?http://www.destinationURL.com" > 
 

 

 

 

 

 

 

 

 

PLEASE NOTE!!!!
Please select '_blank' in the Window field of the Actions dialog.

this makes sure that your ad loads in a new browser window, instead getting trapped in the space of the ad itself.
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Below is a workflow diagram of how the variable is passed from the Macromedia Flash 
advertisement to ad serving network, then redirected to the URL. 
 

 

 

 

Additional information 
A good way to learn more about buttons and their construction is to study the buttons included as 
samples with Flash. In Flash 5, these sample buttons are available from the Windows > Common 
Libraries > Buttons menu. Flash 4 users can access these buttons by choosing Libraries > 
Buttons. For Flash 2, the libraries of sample buttons are accessible from the Xtras menu.  

A walkthrough of creating a button is also available in the Lessons that come with Flash 5. 
Choose Help>Lessons>06 Buttons from within Flash to access this lesson. 

For more details about buttons, see Flash button resources (TechNote 14427). 
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Ad Serving Network’s Guide to trafficking Macromedia Flash banners 
 
Macromedia Flash movies can be made trackable using GET URL () and variables. 
 
Example  

 

The example above has dynamic click through variables added to the <OBJECT> and <EMBED> 
tags of the HTML source file after publishing. 

This works if the user has the Macromedia Flash Player version 4 or above. 

After the HTML source files are published, a variable is added. This variable is called "clickTAG" 
in the example, because it is a click code and destination URL that are being passed in. 

The “clickTAG” variable is a click code and destination URL read by the Macromedia Flash 
(SWF) file, then passed to a GetURL() command in the file, which navigates the browser to the 
http://www.destinationURL.com page. 

Example of a JavaScript OBJECT EMBED tag (key areas in red) 
This tag passes in a clickTAG variable with the value 
“http://adnetwork.com/tracking?http://www.destinationURL.com". The JavaScript within the page 
will pass a variable named "clickTAG" into the Macromedia Flash (SWF) file. 

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000 
codebase="http://download.macromedia.com/pub/shockwave/cabs/ 
flash/swflash.cab#version=4,0,0,0" 

ID=ad_banner_example1 WIDTH=468 HEIGHT=60> 

<PARAM NAME=movie VALUE="ad_banner_example.swf?clickTAG 
=http://adnetwork.com/tracking?http://www.destinationURL.com">  

<PARAM NAME=loop VALUE=false>  

<PARAM NAME=menu VALUE=false>  

<PARAM NAME=quality VALUE=medium> <PARAM NAME=bgcolor 
VALUE=#FFFFFF> 

<EMBEDsrc="ad_banner_example.swf?clickTAG=http://adnetwork.com/tracking
?http://www.destinationURL.com" loop=false menu=false quality=medium 
bgcolor=#FFFFFF swLiveConnect=FALSE WIDTH=468 HEIGHT=60 
TYPE="application/x-shockwave-flash"> 

</EMBED> 

</OBJECT>
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Get best results with Macromedia's rich media recommendations  

Macromedia suggests the following guidelines when creating a rich media campaign. Although 
guidelines may vary between sites and ad management systems, we have found that these are 
the most generally accepted. 

· Size of banner ad 
· Looping animations  
· Testing  
· Delivering banner ads to ad serving networks 
· Delivering both Macromedia Flash SWF and default GIF banner ads 
· HTML Publish settings 
· GIF Publish settings 
· Frame Inspector setting 

 

Size  

Width 468 pixels 

Height 60 pixels 

SWF file size, maximum 15k 

Default GIF file size, maximum 12k 

Animation loops, maximum 3 

When passing data between Macromedia Flash and a Web server, use the "Get" command 
rather than the "Post" command. 

Looping  

In a Macromedia Flash movie (unlike in a GIF animation) you can add a loop (repeat the movie) 
without adding to the size overhead. Nevertheless, the Macromedia Flash banner specifications 
recommend a maximum of 3 loops. 

Testing  

Before launching, test your banner ad on all browsers that Macromedia Flash currently supports. 
If you use JavaScript to detect the presence of the Macromedia Flash Player, make sure that the 
script fails elegantly when it encounters a browser that does not support either Macromedia Flash 
or JavaScript.  

For more detailed information, please refer to the Macromedia Flash Deployment Kit. 
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Delivering banners to ad serving networks 

When you have finished making your Macromedia Flash banner ad, you will have four end 
deliverables: a Macromedia Flash SWF file, a default GIF image file, the encapsulating HTML, 
and a JavaScript code block that displays the default GIF banner ad if the Macromedia Flash 
Player is not detected. 

Delivering both Macromedia Flash SWF and default GIF banners 

Macromedia Flash's "File>Publish Settings" command automatically publishes both your 
Macromedia Flash SWF banner ad and the default GIF version of your banner ad. The GIF is will 
appear if the user doesn't have the Macromedia Flash Player. When using HTML publishing 
settings and setting the template to "Ad Any Banner" it will output HTML with JavaScript, which 
contains a block of JavaScript code that allows you to deliver both the SWF and the GIF files.  

The default GIF banner will be a static image. It will be of the first frame of your movie, unless you 
specify a different frame by labeling it "#Static".  

If you would like the default GIF banner to be animated, go to GIF > Publish and choose 
Animated. The animated GIF will include all the frames of your movie, unless you specify a range 
of frames by labeling the appropriate ones "#First" and "#Last". 

HTML Publish settings 
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GIF Publish settings 

 
 
Frame Inspector setting 

 
Enter the label "#Static" for the frame you want to export as a GIF. 




